Displays the grid
Sets the snap snep. You can type your own value.
Sets the zoom-factor. You can type your own value.
Toggle the edition-mode between group-mode and single-object mode.


File menu
Newcreate a new drawing sheet.
Openload an existing file from disk.
Reloadreload current drawing from disk
Savesave current file in LaTeX, epic or PsTricks format, depending on the current content-type; default directories can be specified in the preferences tabsheet.
Save Aslet you choose another file name.
Save Allsave all currently open sheets.
Save Selection Aslet you save only selected (namely : highlighted) parts of your drawing ; useful to create fragments ; the user's fragment directory is automatically pre-selected in the file-chooser, but you can save fragments in other places...
Insert Fragmentinsert a prerecorded fragment into the current active sheet (the topmost internal frame), placing it in the bottom-left corner of the frame ; by default, the filechooser points to the user's fragment directory, but you can obviously insert fragments from other places...
Recent Filesthis mutable menu keeps track of the last four loaded or updated files, and let you quickly load one of them.
CloseClose active frame
ExitSave every open sheet to disk, then quit.
Edit menu
Undo/Redoundo/redo last change (the number of undoable steps is specified in the preferences menu).
Cutcut current selection and send it to clipboard.
Copycopy selection to clipboard.
Paste paste selection from JPicEdt graphic clipboard, starting from bottom-left corner.
Paste special paste selection by trying to parse the content of the system clipboard. For example, you may first copy a LaTeX string to the system clipboard from your favorite editor, then paste it to jPicEdit using PasteSpecial. This can obviously lead to a parser-error if the text content is not syntaxically correct.
Under Linux, use xclipboard to copy a piece of text to the primary selection... Direct data transfer b/w the jEdit editor and jPicEdt works flawlessly however.
Select All select every object in the current board.
Page format set the page format of the current drawing board, if any. If there's no open board, set the default page format for new boards (this is identical as setting the page format from the Preferences).
Content type set the content-type of the current drawing board, if any. This sets the formatter used to format the current drawing to LaTeX (i.e. LaTeX picture env, epic or PsTricks), and also affects the way elements are displayed (for example, colour is supported by PsTricks only, filling ellipses by PsTricks and eepic only,...).
Preferences opens the "set preference" tab. See setting preferences.
Attributes editor toggle the visibility of the floating "set attribute editor". This can be useful on laptops, because this palette takes up a significant amount of the screen ;-).
Command menu
LaTeX run LaTeX on the current drawing; to sum up : jPicEdt creates a temporary LaTeX file on-the-fly, containing all the necessary stuff (see how to set the prolog and epilog in the preferences tabpane), in the temporary directory of the underlying platform (e.g. /tmp under Unix and MacOS-X, c:\windows\temp under Win9x,...) then run LaTeX on it.
Contrary to previous releases, you don't need to save your picture anymore before running the LaTeX/DVI/etc... commands.
Dvi viewer same thing, but run a dvi viewer on the same file (actually the one with a ".dvi" extension, which then assume you ran LaTeX before).
Dvips run the referenced Dvips program.
Ghostview run the referenced Ghostview program.
External program path and names (as well as their calling syntax) can be specified in the preferences.
Fragments menu
List of fragments Depending on fragments found in the system-wide's and the user's fragments directory, you may see zero, one or more items here. Click to insert. Fragments saved by user go into the "fragments" subdirectory of the user-settings directory (for instance : /home/user/.jpicedt/fragments on Unix).
Rescan Rescan the list of fragments.
Script menu
BSH Console Open a BSH Console for interacting on-the-fly with jpicedt, or for debugging your scripts.
List of scripts Depending on scripts installed in the system-wide's and the user's script directory, you may see zero, one or more items here. Click to run.
Rescan Rescan the list of installed scripts from the script directory.
Window menu
Cascade cascade all internal windows.
Tile horizontal tile windows horizontally, creating as new rows as necessary.
Tile vertical tile windows vertically, creating as new columns as necessary.
Window menu also maintains a list of currently open sheets so that you can quickly switch between them (Note : keyboard shortcuts may not work on Linux and MacOS platforms).